V0.30 is pedal range now bugged?

I just updated to 0.30 yesterday to see how my expression pedal worked now with the fix.
It seems and feels like I get the full 0 to full range now, but it doesn’t actually kick in before my pedal is at about halfway pressed down.

So while the update fixed the range, by doubling the range, it seems to have halved the usable range on my pedal?
Can anyone else confirm?

Maybe it’s based on the envelopes’ attack response, where the first half of the travel makes almost no perceivable difference? :wink:

Sent in a bug report, but still curious if anyone else is experiencing the same thing now.

I really must try the pedal input again. It’s one of several mod sources I rarely bother with but I have a pedal somewhere, will give it a go. I did experiment with that input and incoming CV (a Sample & Hold module) but there was so much smoothing applied I quickly abandoned the idea.

I made a simple test: use DDS2 and modulate “Tune” by pedal (full range = all LED for positive modulation ON).
In my case (with my pedal), tune (frequency of DDS2) increases linearly as wanted.

I did the same test with the filter frequency, which also worked as expected. Thus, I think everything is ok with the pedal range linearity.


OK tried my pedal (a Korg EXP-2) and it drives parameters as expected in the positive range. If I set the modulation to be negative it acts as if positive, unless the parameter itself is set above zero.

I have a very cheap MGEAR EXP which I set to M-Audio Mode. It works pretty fine.

If I set the modulation to negative values (example: tune of DDS2), pushing the pedal decreases the frequency exactly as I want it to.

There was a post about “calculation” of the modulation:
negative with negative as well as positive with positive → positive
negative with positive or vice versa → negative

Thanks for all the input, I’ll dive in again tomorrow and see what I might have done to get so stumped by the behaviour now.

Cheers, probably just too used to old-style mod matrices

How curious. Now that I try it it seems to behave just fine.
Makes me wonder if I just did something weird before now.

Thanks everyone for the replies.