Cannot get the UDO boot disk to appear on MAC

As above.

Have tried ten times.

It simply will not show up on Finder window.

I’m on Catalina. Is this an issue?

Any tips?

Many thanks.

Same issue just booted it on a Linux pc

It worked for me on my mac mini without any problems. I cant remember which OS Im on but I think its the 2nd newest.

Tips?: try different usb cable, direct input vs usb hub, connect to mac before turning the Udo on or the other way around.

Sorry but you properly tried all these suggestions already?
Let us know if you find a solution to the problem

How long are you holding down shift? Works on Catalina for me.

I’ve never had this problem with any Super 6 firmware version on a bunch of different modern macs with operating systems that were current in the Super 6’s lifetime so far.

Here is the answer to your troubles. Definitely. I would put money on it. You are holding down the WRONG button with Shift pressed, as you start up your Super 6. Check and READ the manual carefully, and you will see I am right. I can’t be bothered to check which is which - you can do the work. One button is bootloader for firmware updates and the other is for patch and waveform management. Now, say “thankyou” nicely.