After upgrade aftertouch is routed to pitch in some of my patches

Im noticing that aftertouch seems to be now routed to pitch in some of my patches that did not previously have this programmed. i play the note as normal but when I engage the aftertouch the pitch rises.
Any thoughts?

Yes, I‘m having the same issue. It‘s really annoying.

My workaround at this point is turning off the Z-Axis on my LinnStrument, when the patch requires a free running LFO2. You cannot have a free running LFO2 AND After Touch (or a Z-Axis on an MPE controller).

Hi, we don’t offer technical support on the forum but please can you send a sample of the affected patch to thanks. I will load it in and see what’s up. I have a linnstrument also. This is not something our testers or public BETAs picked up on so may be patch specific. Appreciate your help and we’ll get it sorted out quickly.

1 Like

This is not patch specific. It’s an issue that always occurs if you set LFO2 to ‘free running’ or ‘always on’ (MODE-switch: both LEDs unlit). Even the V1.0 init patch does this, if you set the LFO2-MODE-switch to both-LEDs-off. Of course, as a LinnStrument user, I usually turn on MPE on any Super6 Patch (MPE-Settings as recommended in the manual: 1 = on, 2 = off, 3 = on).
As soon as you press a key, you’ll hear a rising pitch. The harder you press the key, the higher the pitch.

On Page 78 of the Super 6 manual I found this:

• NONE: When no LED is lit, LFO 2 is permanently on. Additionally, aftertouch is now set to trigger the same modulations controlled by a pitch bend wheel.

If I understand this correctly, the (in my case: unwanted) aftertouch → pitch bend routing is actually intended, isn’t it?
I don’t know if this is a usable feature for people who play conventional keyboards. For LinnStrument users this basically means, that if you want to have an ‘always on’ LFO2, you’ll have to turn off LinnStrument’s Z-Axis (channel pressure, Aftertouch).

This issue did not occur with firmware V0.53.

Looking into it, the effect is specific to patches where LFO2 is on with polyphonic pressure source. In this case AT is routed to Bend channel.

This is to allow pressure to be mapped easily to VCF cutoff and Pitch for either oscillator (DDS) using the panel controls on KB (note coming poly aftertouch kb for super 6)

The mapping can be reduced to zero by pulling down the DDS and VCF faders left of keyboard (bender x). For desktop set the bend range to zero by pressing and holding bend in MOD ASSIGN mode and press C4 (VCF range should be automatically 0)

While this is intended behaviour, we have reverted polyphonic pressure mapping to 0,53 behaviour for now whilst we figure out how to make operation clearer.

Keep eye on website for coming update very soon

Thanks for looking into this. I have a similar issue where my expression pedal seems to be rooted to the bender where it wasn’t previously so using the expression pedal changes the pitch when it didn’t before the update. Could this be related?

@JIMSUTH is this also with MPE controller?

Hi, No not exclusively. its tricky for me to see exactly what is going on in the modulation but it seems to be when I have the exp pedal connected to the cross mod and the sub oscillator is selected.
Does this make any sense to you?

@JIMSUTH Ahh yes that’s because in sub osc mode, DDS2 becomes and LFO (range fully CCW). This means that cross mod is actually LFO to pitch in this mode.

But the effect is different from the previous firmware. It sounds quite different. What has changed?