S6 Desktop issues after V1update in MPE-mode w/ LinnStrument

Hi there!
I have updated my Super 6 Desktop‘s Firmware to Version 1.0 today.
While I noticed that the Delay Time LED is finally working (:+1:), I encounter an issue that makes lot of my patches unusable: somehow the Z axis (channel pressure) of my LinnStrument is linked to pitch modulation. I tried to find a corresponding setting in the Mod Matrix and get rid of it, but I can’t find it. The harder I press a key on LinnStrument, the higher the pitch gets.

How do I turn this off?

there’s now multiple options in the globals/shift under MPE. I have no idea what they do since the manual hasn’t been updated yet. maybe enabling one of these will help?

make sure aftertouch isn’t routed to the pitch via the right hand slider ===> threeway toggle on AT+BEND and the white DDS slider up (the one you would use to assign pitchbend wheel to osc pitch)

On the S6 desktop I found pressing the LFO2 mode button so that MW was selected would stop the channel pressure message from bending the pitch.

I also noticed CC74 no longer opens the filter. I’m happy that we now have an assignable Y-Axis parameter with CC04 but just wanted to mention CC74 wasn’t working in case that was unintended.

Thank you for the replies.

The AT/LFO2 routing does not cause the unwanted pitch modulation. EDIT: it actually does, but not in the way that I thought of. The pitch bend issue is there, if you don’t assign LFO2 to MW or AT.
CC74 or Y-axis assignment does not cause it either.

Not all of my saved patches are affected, just some of them. Unfortunately the new V1.0 init patch does show the unusual pitch modulation, too.
The only change I have made to my instrument was the firmware update. It worked perfectly fine before. I would go back to V0.53, if there was a way.

All of my patches share the same MPE-settings ( Options 1 = on, 2 = off, 3 = on), which are the recommended settings for LinnStrument.

Turning off Z-axis/channel pressure on the LinnStrument turns off the unwanted pitch mod. This is not a solution for the issue, but it confirms that the annoying pitch mod is linked to the Z-axis.

Okay, I’ve taken a closer look again:
According to the manual, page 78, this is apparently intended. If I do not assign LFO2 to either the modwheel or AT, i.e. if both LEDs on the MODE switch are off, LFO2 runs freely. That’s nice. Problem: at the same time, however, AT triggers a pitch bend, which makes the Super 6 unplayable with a Linn instrument. This ‘feature’ did not work in firmware 0.53, otherwise I would have sent the Super6 back to the dealer.

Is there a way to switch it off? Otherwise I either have to switch off the Z-axis on the LinnStrument (which I would otherwise assign to other parameters like e.g. volume rather than the pitch) or I have to assign LFO2 to the modwheel - the LinnStrument has no modwheel. Conclusion: after the FW update I have synth with one LFO as LFO2 is unusable for LinnStrumentalists. Seriously?

1 Like

It is possible to set it up so that aftertouch wont trigger a pitch bend, but the LFO2 will still be running.

Page 102 of the manual starts to go in that direction when it says this:

“To allow polyphonic aftertouch to be mapped through the modulation matrix only, set LFO 2 to be permanently ‘on’ by toggling the leftmost switch in the keyboard model’s performance control section to ON (AT → BEND) or by pressing the desktop model’s LFO 2 MODE button until both of its LEDs are unlit (options MW and AT disabled).”

However I think you already got that part sussed, and whats missing is another step. I have the keyboard version so the controls arent the same, and Im not sure if the same will apply with the desktop version:

On my keyboard version, the additional step I have to perform is to turn right down the slider which tells it how much bend should affect pitch. This doesnt stop proper MPE pitch bends from working, but it does stop the polyAT (MPE Z) from triggering bends, so I can then use an MPE controller properly with this synth.

So the question is, how do you perform that same operation on the desktop version? On the face of it, I only see buttons that will affect that for LFO2, and I dont know if these buttons can also be made to work for the unwanted bend for your use case using the desktop model.

If you are desperate for a temporary work around and my previous post doesnt turn out to be much good for the desktop unit, look at the Linnstrument manual for ‘Low Row’ ‘X=CC1’ stuff, which will let you have a virtual mod wheel on that device. And it has two modes, so you can use it as something that only retains its value while being pressed, or something where the values stick.

I am not proposing that this is an optimum solution, just something.

If they have broken CC74 in MPE mode then I’d like to take this opportunity to beg once again for them to implemented the mod-sourceable MPE Y as CC74, not CC4. Because it is not safe to assume that users can simply alter the config of their MPE controller to use 4 instead of 74 for this expressive dimension. For sure most controllers let you do that, but it breaks the MPE spec and therefore stops MPE working properly with certain DAWs that actually implemented the MPE spec and dont let other CC’s through on MPE note channels. eg I cannot use Ableton Live and the Push 3 properly with Super 6, the DAW will only handle CC74 in MPE mode and so I have to write my own MIDI conversion software that sits in between the DAW MIDI output and the Super 6 to turn all the CC74s from Ableton into CC4s. Same sort of story if I want to use a MPE hardware sequencer like the Sqarp Hapax.

Unfortunately the AT → Bend switch does not exist on the Desktop model.

Right now my workaround is either turning off the LinnStrument’s Z-axis or setting the LFO2-Mode to MW. The latter basically turns off LFO2, unless you use a Modwheel.

Using LinnStrument’s Low Row Modwheel option could work in some way, but this nothing like having a free running LFO2 with Tempo sync, etc.

All I need is a possibility to turn off the AT-> Bend assignment.

I wonder what happens if someone with the keyboard version saves a preset with the correct desired settings, and then you load it into the desktop version and use it as a starting template.

Unfortunately Im not in a position to do this at the moment, maybe someone else will oblige or UDO could chime in about this.

Interestingly I haven’t had an issue with Linnstrument pressure triggering pitch bend, but I can’t get the Y axis to do anything to Super6. Is this due to CC74 v.s. CC04 situation?

Whats your setup?

If you are going straight from Linnstrument to Super 6 then you should be able to reconfigure the Linnstrument to use CC4. See the “Hidden setting: Y Axis Message Select” section of https://www.rogerlinndesign.com/support/linnstrument-support-panel-settings

Then you will need to make sure you’ve assigned that dimension to do something in the Super 6 patch you are working on, using the appropriate modulation source and destination.

And of course you will have to change those Linnstrument settings back to the normal CC74 when you want to use it with something other than the Super 6.

If you are going via a DAW with tight MPE specification support of MPE (rather than just letting everything through on all MIDI channels) then there will be the problem I mentioned a few times on the forum already. Where this use of CC4 by Super 6 in MPE is non-standard and will not work with these DAWs, those messages wont pass through the DAW MPE tracks successfully.

Oh cool thank you for that!
I’m going straight from Linnstrument to Super6 so am in luck it seems.

1 Like