Aftertouch not functioning

After today’s news that the S6 will have an optional keybed upgrade soon, I wanted to try my S6’s aftertouch out to see if upgrading it would make sense. Turns out the aftertouch on my S6 seems completely dead. (I play it regularly so I’m not sure how I didn’t notice this before.) I tried connecting AT to multiple mod destinations–no response. Same thing with LFO2 on its middle setting. I tried a global reset and that didn’t work. I tried connecting another keyboard with AT to the S6 and that did work (the AT + mods seemed to respond as normal). Any thoughts on how to fix this?

Did you really push the keys hard enough? In Super 6 case, you really have to push hard at the end of the key travel until aftertouch “switch” is enabled.
Another possibility is that the cable inside Super 6 is disconnected. You find it when opening the housing, its under the keybed at the left side of the synth.

Thanks for the input! Yes I really mashed the keys to make sure it wasn’t that. My S6 recently got professionally repaired (it had a power supply issue) so I bet your comment on the cable being disconnected is the culprit–maybe it came loose during shipping or something. I don’t feel confident in taking it apart so the plan is to wait for the MPE keyboard upgrade.

it is super easy to open a super6. you only need to undo both side cheeks screws (5xT20 screws with washers) and 2x T20 screws with washers between the bender and the leftmost key. Then you open up the lid just a bit like 10-20 degrees ( otherwise you would unplug the Aftertouch cable by opening if it was not) and look for your Aftertouch cable left from the bender. if it is hanging, it was off.
By putting it back in you need to twist it 180 degrees. but there is no chance to connect it wrong since the connector is not symmetrically shaped.

There is very little you can do wrong. And you are very far away from the mains that are literally on the opposite side of the device.

hope this helped


1 Like