My 'DYNAMICS' toggle switch doesn't seem to do anything

I’ve only had my Super Gemini a few days, so I’m still exploring all the functions and working my way through the user manual…

On page 43, it explains the DYNAMICS toggle switch. Seems straightforward (sets keyboard velocity to modulate the VCA level and VCF cut-off) - but I cannot hear any difference between either of the three settings!
I presumed it was simply the case that there’d be some other parameter I need to adjust elsewhere to work in conjunction with it… but doing CTRL-F to search the PDF manual for ‘Dynamics’, I can’t anything else that’s relevant. What I am doing wrong? :upside_down_face:
(I’m trying this in Patch mode, after selecting the Init Patch, and adjusting the Upper layer, with the keyboard in Single layer mode)
My SuperGemini firmware is the most recent (v1.12)

It might be adjusting the velocity response of the envelope depth. So if you have little or no envelope depth set on the filter, you may not hear a difference.

Well, this is what the user manual says:

The DYNAMICS toggle switch allows you to determine whether and to what extent the VCA level and the low-pass filter will respond to keyboard velocity:
• OFF: With this setting, the VCA level and the low-pass filter remain unaffected by keyboard velocity.
• 1/2: With this setting, the VCA level and the low-pass filter respond with half intensity to keyboard velocity. The harder you hit a key, the louder and brighter the sound becomes. Use this setting for subtle velocity effects.
• ON: With this setting, the VCA level and the low-pass filter respond with full intensity to keyboard velocity. The harder you hit a key, the louder and brighter the sound becomes. Use this setting if you want the velocity to have a significant impact on the sound, for example if you want to emulate the behaviour of acoustic stringed instruments.

Do I have to also route velocity through the modulation matrix or something like that, for this switch to do anything?

If I toggle the Dynamics switches with a Performance or Patch(s) loaded,
the LED in the corresponding selector button starts to flash,
so the toggle switch itself seems to work (i.e. the Super Gemini knows I’ve moved it) -
but to be honest I’m not convinced I can hear any velocity sensitivity happening on any of existing factory Performances or Patches that came with the machine.
(It sometimes difficult to be 100% sure, if the patches are doing something whacky!) - whereas I can definitely hear the effect of aftertouch doing things.

So maybe I should actually have called this thread ‘my keyboard doesn’t seem to be velocity sensitive’! :no_mouth:
I guess I should hook my SuperGemini up to a different velocity-sensible keyboard over MIDI and see if the sounds respond differently to that compared to played from its own keyboard … also I can feed the Gemini’s MIDI into my PC and look at the raw MIDI in an analyser and check what values the keyboard is sending…

But maybe before I try all that troubleshooting, there’s an obvious setting I’m missing?

well, I hooked up my SuperGemini to a MIDI diagnostic analyser on my PC -
it confirmed that my SuperGemini keyboard’s velocity sensitivity is definitely ‘working’, and it seems rather sensitive - it’s quite hard for me to generate low Note On velocities, my normal playing seems to his v=110 to 127 range without me really hitting hard.
I guess this may explain why I have been finding it tricky to notice any Dynamics effect.

For a comparison, I tried playing the SuperGemini from my Kawai VPC1 MIDI controller (on which I can easily produce a much broader range of Note On velocities by normal playing) and I could immediately hear the Gemini respond to the velocity.
However the response seems to be to the VCF, I can’t make it do anything to the VCA. #baffled.

Think I’m gonna have to email UDO Support on this one.

When I first started I had this problem. I was coming from regular fully weighted piano keys. Now I’m more used to SG and my range is 50-90 playing comfortably. Not sure if that’s any help…

I honestly don’t think my playing could ever change enough to get a normal velocity range out of my Gemini’s keyboard as it currently stands!
I’ve asked UDO Support if it might be faulty or miscalibrated?!

Had a similar issue, contacted support and asked them if it would be possible to adjust velocity curves in the keyboard in a future firmware update. They said they’ll take it into consideration.

But yeah, can confirm that MIDI velocity is extremely top heavy - usually getting around 90-100 when playing “normally”.
Also the dynamics toggle doesn’t affect the VCA and VCF directly, it “scales” the mod depth of both filter and amplitude envelopes.
If you want to experiment with full dynamics, I’d highly recommend driving it with a MIDI controller that you feel more comfortable with. The difference is night and day IMHO.

Yep, UDO Support confirm their machine’s velocity response behaves the same, and they added my +1 to the feature request for a different velocity curve.

It’s a surprisingly inept ‘implementation choice’ for a flagship £3½ grand polysynth where one of the main selling points is supposed to be its luxuriously playable keyboard, to be honest!
In fact it smacks more of some engineers being clueless and not paying attention to what they’re doing. It’s not like MIDI Note On velocity sensitivity is a new technology! It seems I’m not the only person to find the keyboard behaviour a bit crap in this regard…

Honestly, I bought the SuperGemini out of a choice of half a dozen major player polysynths on the market, because I thought ‘no matter what the sound engine is like, it has the best keyboard’ (PolyAT and ribbon) … so I could buy module versions of other polysynths :face_with_hand_over_mouth: and play them from the Gemini…
It simply never crossed my mind that I’d need to check it’s velocity sensitivity wasn’t squished into the top 10% of the range! Why would anyone do that?!?
I almost feeling stung enough to want to send the thing back to the shop - if I’d bought it in one lump sum on credit card, I could - but I opted for an 18 month interest free credit, so it’s not so easy :face_with_raised_eyebrow:

Fingers crossed they fix the velocity soon in a firmware update! Then I can stop moaning :laughing:
But kinda wishing I’d gone for an Arturia Polybrute right now :sweat_smile: