Problem with 1 voice

The problem is that one voice actually does go entirely silent until you power cycle.

If you tap the same key 6 times it’ll be silent in one key press. I did actually report this on one of the really early firmwares when it first shipped out to customers, but it’s still happening now and then.

4 Likes

Yeah definitely sumbit a report!

It happens occasionally here as well but a power cycle resolves it. I also couldn’t reproduce it though.

Well, for now the firmware update and voice reset seems to have solved the problem. I’m just glad I don’t have the send the Super6 back to UDO.

Pasting this reply from onejedinight at gearslutz forum:

Turn on the Super 6.
Press and hold the MANUAL button for 5 seconds until all LEDs turn off and on again.
Release the MANUAL button.

I later worked out this was actually due to the external clock sync being activated without any external clock.

3 Likes

That’s useful to know.
I might have a go at working on reproducing it this weekend. I did for sure lose a voice with 0.26 as well when sequencing from my DAW.

1 Like

I was able to reproduce a few bugs consistently and work out why they happen.

In short, the Super 6 has a problem keeping track of how many note on and note offs it has per voice, and if a note overlaps into an already playing note, the note gets stuck, as it only receives a single note off to its 2 note ons.

Depending on your sequencer/daw of choice, this may or may not be an issue to you.
I noticed Ableton Live prevents this from happening, so I can’t make this happen there (at least I wasn’t able to).

However, Cubase which is my main daw, handles this differently. If you have 2 of the same note overlapping, Cubase will send out corresponding note on/offs for both overlapping notes, but Super 6 only receives one of those note offs.

Setting this up in Cubase is as simple as making a midi track, play 2 of the same note, and drag one note over the other so they overlap. In Live, this will automatically cut the overlap, shortening one of the notes.
Cubase wont, so it’ll have 2 notes that play into each other.

Now if you were to make a really fast arpeggio in cubase, and have note length longer than the step length, you will cause this to happen…and as this will make the number of note ons without a matching note off increase quite rapidly, it’ll eventually cause Super 6 to lose the voices completely, making it unable to play a single note anymore. Neither with its keyboard or by MIDI.

Before I thought the only way out of this was to power cycle, but it seems like this can also be cured by sending it note offs…as many note offs as it takes to correct the issue of the mismatch.

I “fixed” this on my end now, by duplicating note offs, as a way to do housekeeping in the midi signal.
So for any note off that is sent over midi, I add another note off. This fixed both my stuck notes, as well as dead voices.

Cubase isn’t at fault here, as all messages come with a matching note off, but Super 6 doesn’t seem to keep up correctly.

I will fill out a bug report to UDO about this, but I figured I’d also post my findings here in case anyone else has issues here.

Also, it’d be interesting to hear which sequencer people are using if they get this problem.

4 Likes

Cool you found the bug, do submit it to UDO, am sure they will sort it out.

No external sequencer use here yet, waiting for USB MIDI.

1 Like

Great bug investigation report Shor. I also occasionally experience sustained note when I edit with Studio One.

I also reported a related bug with keytrack enabled when using an external master keyboard. If you trigger a note below the assigned octave range on the S6, the release isn´t triggered properly and it just cut off the note. So when I play the lower register on my 88-key Nord Piano the bass notes stop immediately when I release the keys. If you shift the down octave range on the S6 the bass notes release properly.

Sent in a bug report now. A bit more details than on here for more specifics on how to reproduce if needed.
I hope they can work this out. Glad to figure it out at least. Kinda tricky as it’s not the same in all daws/sequencers.

2 Likes

Yep - well done for breaking this down!

I had this issue but wasn’t sure it was something i was getting wrong…

I must say that really is the most frustrating thing with this synth…not knowing if there is a bug or something i’m not understanding in the signal flow / synthesis. grrrrr.

It’s pretty tricky working some things out for sure. As long as you can reproduce something that tends to help breaking it down and working out what causes things.

Which DAW are you using btw?

this happened to me without using a DAW, with no external midi connections at all.

I knew it was a fault with the voices in the end because if i switched to non-binaural mode it would lose 2 of the 12, rather than 1 out of the 6…unlikely to be intentional

But I haven’t replicated it recently so wasn’t quite sure what was going on and or when.

Ah yeah that has actually happened to me as well without midi. I think it was something I was doing with an arp… haven’t had it happen to me in a while though, but it’s quite likely the same thing. Very fast tempos and longer notes make it more likely in MIDI.

For me it happened without a daw, just by playing the keyboard.

Maybe issue with voice card initialization? When I experience this issue it was immediately after power on.

Possible. I’ve not run into it for so long that I can’t say… did you get it with firmware 0.26 as well?

Not yet but its been to short a time to conclude.

I have also run into this issue at random while playing keys (no MIDI) when creating patches. I can’t figure out what exactly causes it. But, at the beginning when starting from an INIT patch all 6 voices sound in binaural mode without issue.

Then after a bit of tweaking various parameters, one of the 6 voices will disappear (pressing a key 6 times and 5th or 6th voice will not trigger).

Re-initializing the patch and all 6 voices are working. So it must be something that happens when adjusting one of the parameters.

I will keep an eye on it and try to figure it out and submit a report if I can replicate it.

4 Likes

yep having the same issue